Go Back   Forums @ The Digital Fix > Entertainment Discussion Forums > DVD and Blu-ray Discussion

Notices

Reply
 
Thread Tools Display Modes
Old 29-12-2014, 10:59   #1
Rob
Indie Author
 
Join Date: Sep 2000
Location: Manchester, UK
Posts: 4,009
Thanks: 34
Thanked 88 Times in 44 Posts
Dawn of the Planet of the Apes Blu-Ray

Anybody else having problems playing this blu-ray?

Got the Rise / Dawn double set for Christmas and "Dawn" won't play on my Sony BDPS370 Blu-ray Player.

Fantastic service from Amazon, they got a new set to me within 2 days, but guess what - the next disc is exactly the same.
__________________
"Well I feel like pickin' a fight with anybody who claims they're right"
Rob is offline   Reply With Quote
Old 29-12-2014, 12:10   #2
Wowbagger
Don't tell him, Pike
 
Wowbagger's Avatar
 
Join Date: Jul 2002
Location: Between the land and the sky
Posts: 3,139
Thanks: 216
Thanked 120 Times in 95 Posts
Looks like a firmware update is necessary. I got the 8-disc set recently and I assume it's the same disc. I have that player and thought I'd better check when I read your post. I got a firmware update message. I rarely connect this player to the net but I bunged in a cable and did a network update. Took about 2 mins and now the disc plays fine. (Setup > network update.)

Last edited by Wowbagger; 29-12-2014 at 12:12.
Wowbagger is offline   Reply With Quote
Old 29-12-2014, 12:27   #3
Rob
Indie Author
 
Join Date: Sep 2000
Location: Manchester, UK
Posts: 4,009
Thanks: 34
Thanked 88 Times in 44 Posts
Quote:
Originally Posted by Wowbagger View Post
Looks like a firmware update is necessary. I got the 8-disc set recently and I assume it's the same disc. I have that player and thought I'd better check when I read your post. I got a firmware update message. I rarely connect this player to the net but I bunged in a cable and did a network update. Took about 2 mins and now the disc plays fine. (Setup > network update.)
Thanks Wowbagger - I'll give it a try when I've got a moment. At the theatre this afternoon so might not get a chance 'til later
__________________
"Well I feel like pickin' a fight with anybody who claims they're right"

Last edited by Rob; 29-12-2014 at 12:29.
Rob is offline   Reply With Quote
Old 29-12-2014, 17:44   #4
MK20
Registered User
 
Join Date: Sep 2000
Location: SHEFFIELD
Posts: 265
Thanks: 0
Thanked 0 Times in 0 Posts
I had the same thing with this disk and my Philips player. The player read the disk then spit it out with no message. I got the latest firmware online, installed it and the disk now plays fine (although does take a while to load).


Sent from my iPhone using Tapatalk
MK20 is offline   Reply With Quote
Old 29-12-2014, 20:14   #5
Rob
Indie Author
 
Join Date: Sep 2000
Location: Manchester, UK
Posts: 4,009
Thanks: 34
Thanked 88 Times in 44 Posts
Quote:
Originally Posted by Wowbagger View Post
Looks like a firmware update is necessary. I got the 8-disc set recently and I assume it's the same disc. I have that player and thought I'd better check when I read your post. I got a firmware update message. I rarely connect this player to the net but I bunged in a cable and did a network update. Took about 2 mins and now the disc plays fine. (Setup > network update.)
Once again, thanks - did the f/w upgrade and the disk now works fine.
__________________
"Well I feel like pickin' a fight with anybody who claims they're right"
Rob is offline   Reply With Quote
Old 30-12-2014, 01:08   #6
Wowbagger
Don't tell him, Pike
 
Wowbagger's Avatar
 
Join Date: Jul 2002
Location: Between the land and the sky
Posts: 3,139
Thanks: 216
Thanked 120 Times in 95 Posts
Good stuff! First time I've had to apply an update to play a disc.
Wowbagger is offline   Reply With Quote
Old 30-12-2014, 10:47   #7
Rob
Indie Author
 
Join Date: Sep 2000
Location: Manchester, UK
Posts: 4,009
Thanks: 34
Thanked 88 Times in 44 Posts
Same here. Glad I had a wif-fi extender and spare LAN cable, otherwise I'd have had to drag one of the kids TVs down to site it next to the main computer. Anyway, we're all looking forward to finally watching the film tonight.
__________________
"Well I feel like pickin' a fight with anybody who claims they're right"
Rob is offline   Reply With Quote
Old 30-12-2014, 14:18   #8
dmb6473a
Trusted User
 
Join Date: Mar 2001
Location: West Midlands
Posts: 5,489
Thanks: 49
Thanked 62 Times in 54 Posts
I had the same problem with the Sony, but ended up playing it in the Xbone rather than updating.
dmb6473a is offline   Reply With Quote
Old 01-01-2015, 20:31   #9
Raigmore
Ambassador to Earth
 
Raigmore's Avatar
 
Join Date: Feb 2001
Location: David Vincent's neighbour
Posts: 7,550
Thanks: 210
Thanked 148 Times in 106 Posts
Interesting. I have a 5-year old Panasonic DMP BD65 which I have updated 3 times since purchase but the last one was almost 3 years ago. There have not been any more updates since then on the Panasonic website. So far I have not had any play problems with modern films and after reading this thread I went and unwrapped my BD of DOTPOTA and played it. The player took a wee bit longer...perhaps 20 seconds...to recognise the disc but then played it like a dream.

Could this be a Sony specific problem?
Raigmore is offline   Reply With Quote
Old 01-01-2015, 20:53   #10
malcy
Member
 
Join Date: Aug 2002
Location: Stockholm
Posts: 3,609
Thanks: 55
Thanked 129 Times in 87 Posts
Quote:
Originally Posted by Raigmore View Post
Interesting. I have a 5-year old Panasonic DMP BD65 which I have updated 3 times since purchase but the last one was almost 3 years ago. There have not been any more updates since then on the Panasonic website. So far I have not had any play problems with modern films and after reading this thread I went and unwrapped my BD of DOTPOTA and played it. The player took a wee bit longer...perhaps 20 seconds...to recognise the disc but then played it like a dream.

Could this be a Sony specific problem?
My Sony 570 had a firmware update on 29th December, first in over a year. Reading the Sony support website it says it is to allow the latest BD security keys. I know Fox are the studio who tend to push the envelope by using the latest BD security to try and prevent people ripping disks. Obviously there was a requirement for Sony to allow those disks with the latest security keys to work on their players.

Has not been an issue with my Oppo 93 so must vary on a player and manufacturer basis.
malcy is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Playstation 4 + 5 games and a Dawn of the Planet of the Apes Blu-ray - Ł399.99 @ Game Guest 86752 Bargain Forum 0 20-12-2014 20:43
Dawn of the Planet of the Apes NicolaUK Film Discussion 155 02-12-2014 20:28
Planet Of The Apes Quint Film Discussion 26 13-12-2010 19:58
Planet of the Apes R2 SE Guest 33484 Film Discussion 0 08-04-2004 13:18
Planet of the Apes R1 JohnMac Film Discussion 0 04-11-2001 16:06

All times are GMT. The time now is 13:59.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2000 - 2018 Poisonous Monkey Ltd. Part of The Digital Fix Network